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What does Calendar Master do?
Calendar Master is designed to replace the use of purchased calendars.    These calendars 
are the ones you buy and hang on your refrigerator or office wall, and then start writing in 
appointments, birthdays, and anniversaries.    (If you don't use hardcopy calendars, you 
probably don't need this program).    Some of the problems with this method is that each 
year, you have to re-enter birthdays and anniversaries, repeating appointments have to be 
repeatedly entered, and the calendars frequently get cluttered with scribbles and you run 
out of room.    

Calendar Master lets you enter appointments (called events in Calendar Master), both one 
time and recurring, as well as yearly repeating events such as birthdays and anniversaries, 
and then print out a calendar with those items printed in the various days.    The idea is that
you would enter all the birthdays, anniversaries, or appointments you want to remember.    
You would then print out calendars for the current month as well as the next couple of 
months.    You then use the calendars as you normally would by writing in new 
appointments on the appropriate days.    Periodically, you would fire up Calendar Master, 
enter the changes to the calendars that you have made by hand, and then print out the 
next appropriate set of calendars and start over.

As you can tell, this scheme is best suited for a situation where you don't have your 
computer on all the time or you want to make calendars for someone who doesn't have a 
computer (and access to a PIM).    

Calendar Master is not a PIM.    It will not remember addresses, phone numbers, or remind 
you to pay your bills.    It will print a calendar from any month along with any other 
information you enter into it.    



Getting Started
To run the program, use the Windows File Manager to open the directory where Calendar 
Master was installed.    Double click on the program name (CALMAST.EXE).    

There are lots of other ways to run Windows programs.    Please see your Windows 
documentation for information on how to create Program Groups and Items.    

After the introductory screen you will be presented with the Calendar Display.    This is the 
main window of Calendar Master.    From here you can navigate to various months, open the
Event Editor, open and save Calendar Master information files, print calendars, and exit the
program.    



Viewing a Particular Month
To view a specific month in the Calendar Display, you use the navigation buttons on the left
side of the window.    The month being displayed is shown between the scroll buttons.    The 
inner scroll buttons change the month (the left button changes to the previous month and 
the right button changes to the next month).    The outer scroll buttons change the year.    
You can drag the slider left or right to display previous or future months.    If you click in the 
area between the slider and the buttons, you will jump ahead or back by 3 months.    The 
additional buttons below the scroll buttons allow you to quickly display the current month 
(based on the system clock) or hop directly to a specific month in the currently displayed 
year.    

If you have event information entered into Calendar Master, the number of events (both 
Normal/General and Anniversary events) for each day will be displayed on the calendar.    



Entering Events
Events are added or modified by navigating to the desired month in the Calendar Display 
and then clicking on the day that corresponds to the event you want to add or modify.    This
will bring up the Event Editor where you can enter the time and text of the event or select 
an existing event and modify its parameters.

You can enter Normal events, General events, Anniversary events, or Recurring events.    



Entering/Modifying Normal Events
To enter a Normal event, click in the Time box in the Event Editor.    Type in the time of the 
event in either 24 Hr or am/pm format.    The following are valid times;

This: Means This:
01:30 1:30 in the morning
3:30 p 3:30 in the afternoon
22:45 10:45 in the evening
8:30 am 8:30 in the morning

After entering the time, press the TAB key or click in the Event box and type in the text of 
the event.    You can make the event a Recurring or Anniversary event by clicking the 
corresponding option button.    Note that the time will be ignored in an Anniversary event.    
If you need the time field, make a Normal Recurring event.

When finished entering the event text, press Return, click the Add button, or press Alt + a.  
The event will be added to the Event list at the top of the display.    

To delete an existing event, select the event from the Event list.    The event information 
will be displayed in the Edit area.    Note that the Add button will change to Update and 
the Delete button will become enabled.    Click the Delete button or press Alt + d.    

To modify an existing event, select the event from the Event list.    The event information 
will be displayed in the Edit area.    You can change the time, text, or type of the event in 
the same manner as is done for adding events.    When finished modifying the event, press 
Return, click the Update button, or press Alt + u.

To change the day displayed in the Event Editor, click the scroll buttons or drag the slider 
at the top of the display.    These buttons change the display to either the next day (the 
right button) or the previous day (the left button).    

When you are finished entering/modifying events, click the Close button at the top right of 
the display or press Alt + c.    



Entering/Modifying General Events

To enter a General event, click in the Event box in the Event Editor and type in the text of 
the event.    Don't enter a time in the Time box.    You can make the event a Recurring or 
Anniversary event by clicking the corresponding option button.    

When finished entering the event text, press Return, click the Add button, or press Alt + a.  
The event will be added to the Event list at the top of the display.    

To delete an existing event, select the event from the Event list.    The event information 
will be displayed in the Edit area.    Note that the Add button will change to Update and 
the Delete button will become enabled.    Click the Delete button or press Alt + d.    

To modify an existing event, select the event from the Event list.    The event information 
will be displayed in the Edit area.    You can change the time, text, or type of the event in 
the same manner as done for adding events.    When finished modifying the event, press 
Return, click the Update button, or press Alt + u.

To change the day displayed in the Event Editor, click the scroll buttons or drag the slider 
at the top of the display.    These buttons change the display to either the next day (the 
right button) or the previous day (the left button).    

When you are finished entering/modifying events, click the Close button at the top right of 
the display or press Alt + c.    



Entering/Modifying Anniversary Events

To enter an Anniversary event, click in the Event box in the Event Editor and type in the 
text of the event.    The Time box is ignored for an Anniversary Event.    You can make the 
event a Recurring or Normal event by clicking the corresponding option button.    

When finished entering the event text, click the Anniversary option button or press Alt + v.  
Then press Return, click the Add button, or press Alt + a.    The event will be added to the 
Event list at the top of the display.    Anniversary events are displayed in the Event list with 
an "A" preceding the text of the event.

To delete an existing event, select the event from the Event list.    The event information 
will be displayed in the Edit area.    Note that the Add button will change to Update and 
the Delete button will become enabled.    Click the Delete button or press Alt + d.    

To modify an existing event, select the event from the Event list.    The event information 
will be displayed in the Edit area.    You can change the time, text, or type of the event in 
the same manner as done for adding events.    When finished modifying the event, press 
Return, click the Update button, or press Alt + u.

To change the day displayed in the Event Editor, click the scroll buttons or drag the slider 
at the top of the display.    These buttons change the display to either the next day (the 
right button) or the previous day (the left button).    

When you are finished entering/modifying events, click the Close button at the top right of 
the display or press Alt + c.    



Entering/Modifying Recurring Events
To enter a Normal Recurring event, click in the Time box in the Event Editor.    Type in the 
time of the event in either 24 Hr or am/pm format.    The following are valid times;

This: Means This:
01:30 1:30 in the morning
3:30 p 3:30 in the afternoon
22:45 10:45 in the evening
8:30 am 8:30 in the morning

If you want to enter a General Recurring event, don't enter a time in the Time box.    Note; 
you can't enter a Recurring Anniversary event.

Press the TAB key or click in the Event box and type in the text of the event.    

When finished entering the event text, click the Recurring... option button or press Alt + r.
This will display the Recurring Event dialog.    This dialog allows you to specify the 
parameters of the recurring event.    When finished specifying the information in the 
Recurring Event dialog, press Return, click the Add button, or press Alt + a.    The event will
be added to the Event list at the top of the display.    Recurring events are displayed in the 
Event list with an "R" preceding the text of the event.

To delete an existing event, select the event from the Event list.    The event information will
be displayed in the Edit area.    Note that the Add button will change to Update and the 
Delete button will become enabled.    Click the Delete button or press Alt + d.    The Delete
Recurring Event dialog will be displayed.    This will allow you to delete various subsets of 
the recurring event.    

To modify an existing event, select the event from the Event list.    The event Information 
will be displayed in the Edit area.    You can change the time, text, or type of the event in 
the same manner as done for adding events.    If you change a recurring event to either a 
Normal/General event or an Anniversary event, a message will be displayed explaining that
only the current event (of the recurring series) will be changed.    If this is what you want 
then select OK in the message dialog.    If instead, you want to change the entire series of 
recurring events to one Normal or Anniversary event, then select Cancel in the message 
dialog and then select the Delete button in the Event Editor and delete 'All but this 
event' and then re-select the event and change the type.    

When finished modifying the event, press Return, click the Update button, or press Alt + r. 

To change the day displayed in the Event Editor, click the scroll buttons or drag the slider 
at the top of the display.    These buttons change the display to either the next day (the 
right button) or the previous day (the left button).    

When you are finished entering/modifying events, click the Close button at the top right of 
the display.    



Printing Calendars
To print a calendar, use the navigation buttons to display the desired month (see Viewing a 
Particular Month).    If you have saved information into a Calendar Master file and you 
haven't loaded it yet, you may want to load the file now.    

Ensure that your printer is on and then either click the print button  on the Toolbar or 
choose Print or Print... from the File menu.    Print... brings up a dialog box that allows 
you to change certain printer parameters.    Note, you can only print one month at a time.    
After you have selected print, a percentage complete bar will appear to show printing 
progress.    

Event text will wrap to two lines when the calendar is printed.    Event text longer than two 
lines is clipped at the edge of the day cell on the printed calendar.    This limits the printable 
length of event text to around 50 characters depending on whether it is a Normal or 
General/Anniversary event.

Anniversary events are printed in bold one line below any other events.    

(Note: If you have problems printing (out of memory), you may want to reduce the 
resolution of the printer via the File Print... menu selection (and subsequent dialog box)).



Saving Calendar Master Information
Once you have entered events into Calendar Master, you should save the information into a
Calendar Master file.    These files can then be read back into Calendar Master for updating. 
You can have multiple Calendar Master files which you can use for different purposes but 
only one Calendar Master file can be loaded at any one time.    Calendar Master files should 
have an extension of .CMS.    

To save your event information into a file, click the save button  on the Toolbar or 
select Save from the File menu.    If you have not previously read in information from a 
Calendar Master file, you will be prompted for the directory and filename in which to store 
the event information.    If you have previously opened a Calendar Master file, then the 
current information will be saved back into that file.    If you want to change the name of the
file the information is to be saved into, select Save As... from the File menu.    

Calendar Master files are plain ASCII files which you can look at and edit in your favorite 
text editor.    



Opening a Calendar Master File

If you have saved event information into a Calendar Master file, you can retrieve that 
information and add to it or update it.    You can have multiple Calendar Master files which 
you can use for different purposes but only one Calendar Master file can be loaded at any 
one time.    Calendar Master files should have an extension of .CMS.    

To open a Calendar Master file, click the open button  on the Toolbar or choose Open 
from the File menu.    The File Open dialog box will appear where you can select the 
Calendar Master file you wish to open.    Opening a file will erase any information that is 
currently in Calendar Master.    You should save any event information you wish to keep 
before opening a new Calendar Master file.

You can also specify a file to open when you start the program.    If you specify the name of 
a Calendar Master file following the name of the program CALMAST.EXE when you start the 
program, the named Calendar Master file will be loaded.    The easiest way to do this is to 
setup a program item for Calendar Master in the Windows Program Manager.    See your 
Windows documentation for more detailed information.    

Calendar Master files are plain ASCII files which you can look at and edit in your favorite 
text editor.    



Deleting Event Information
You can delete event information in two ways.    The first way is to navigate to the 
appropriate month, open the Event Editor for the appropriate day, select the event and 
click Delete.    If the event is a Recurring event, the Delete Recurring Event dialog is 
displayed which allows you to select a subset of the Recurring events to delete.    

This method is fine for deleting small numbers of events but can be cumbersome for 
deleting large numbers of events.    

The way to delete large numbers of events is to select Delete Events... from the Edit 
menu.    This is useful for purging the Calendar Master file of old events (which will help 
performance).    Selecting Delete Events... from the Edit menu will bring up the Delete 
Events dialog.    Here, you can choose to delete all events before a certain date, all events 
after a certain date, or all events.    Note that this does not affect Anniversary events.    
Select the desired delete method, the date if applicable, and then choose OK.    

Of course, you must save the Calendar Master file for the changes to be permanent.



Exiting the Program

To exit the program, click on the Stop sign  on the Toolbar at the top of the Calendar 
Display.    You can also select Exit from the File menu.    If you have not saved any changes 
you have made to the information currently in Calendar Master, you will be asked whether 
you want to save the information.    If you choose Yes, the information will be saved in the 
currently open file or, if a file is not open, you will be prompted for a directory and filename.



Registration of the Program
Calendar Master is a shareware program.    This means that you can use it for a period of 
sixty days in order to evaluate it's usefulness to you.    After sixty days, you must either 
register the program or delete it from your system.    

Registration is accomplished by sending $10.00 US., your name, address and any 
comments to the address shown below.

Upon registration, you will be granted a license to use the program and will be put on the 
mailing list for notification of upgrades and enhancements.    



Event Types
Normal Events are events which have both event text and a time.    

General Events are events which don't have a time associated with them.    For example, 
"Payday", "Pay Bills", or "School Pictures".

Anniversary Events are events that happen every year on the same date.    This would 
include birthdays, anniversaries, and some holidays.    Anniversary Events do not have a 
time associated with them.

Recurring Events are events which happen at a certain pattern like "every 3 days for 2 
weeks" or "every month for 2 years".    Both Normal and General Events can be recurring. 



A PIM is a Personal Information Manager.    This is a class of program which is used to keep
track of information such as Names and Addresses, Phone Numbers, Appointments, and 
other miscellaneous information.    



The Toolbar
The Toolbar is the row of buttons at the top of the Calendar Display.    These buttons are 
used as shortcuts for frequently used operations.    

 This button is used to open an existing Calendar Master file.    The corresponding menu 
command is Open in the File menu.    All event information in Calendar Master will be 
cleared before opening the new file but you will be prompted to save any changes you have 
made before this happens.

 This button is used to save the current Calendar Master information in the current file.   
The corresponding menu command is Save in the File menu.    If there is no file currently 
open, you will be prompted for the name of the file to save into.

 This button is used to print the currently displayed Calendar Month.    The 
corresponding menu command is Print in the File menu.    

 This button is used to exit Calendar Master.    You will be prompted to save any changes
you have made to the file before the program exits.    The corresponding menu command is 
Exit in the File menu.

 This button is use to display Calendar Master Help.    The corresponding menu 
command is Contents... in the Help menu.    Remember, Help is available at all times by 
pressing F1.



Delete Events Dialog

The Delete Events Dialog is displayed by choosing Delete Events... from the Edit menu.    
This dialog is used to delete ranges of Normal/General event information.    This does not 
delete Anniversary events.    Anniversary events can only be deleted using the Event Editor.
The Event Editor allows you to delete either one event at a time or subsets of Recurring 
events.    

The Delete Events Dialog allows you to delete all events, all events before a given date, or 
all events after a given date.    If you choose to delete events before or after a date, the 
delete is not inclusive of the events on the given date (before or after, not on).    

Note; you can also read the Calendar Master file into an ASCII editor (like Notepad) and use 
it to delete events from the file.    



Recurring Event Dialog
The Recurring Event Dialog is displayed when you click on the Recurring... option button 
in the Event Editor.    This dialog allows you to set the parameters of a Recurring event.    

There are two basic parameters of a Recurring event.    The first one is the frequency; 
"Every 3 Days", "Every 2 Months", or "Every 1 Year".    This parameter is set on the left side 
of the dialog.    Select the Every box and enter the frequency then click on the drop down 
button on the units list box immediately to the right and select the units.    

The other parameter of a Recurring event is the duration; "Every 3 Days for 2 Weeks", or 
"Every 2 Months until 10/13/95".    This parameter is set on the right side of the dialog.    As 
hinted in the example, the duration can be either some number of units or an end date.    To
set an end date, click the Until option button and then enter the end date in the Date box. 
The end date means "up to and including this date".    Note that an occurrence of the 
Recurring event might not land on the end date.    Thus, if you specify "Every 2 Weeks until 
10/13/95" and 10/13/95 is tomorrow, you will only get one event.

To make the duration some number of units, click the For option button, enter the number 
of units in the For box and then select the units from the drop down list to the right.    

When you have specified the parameters, click the OK button.    If you change your mind 
and don't want to make a Recurring event, click Cancel.    The Recurring event doesn't 
actually get entered into the event list until you select Add or Update in the Event 
Editor.    



Event Editor
The Event Editor is a dialog box that is used to enter and modify event information.    At 
the top of the display is the Day selector.    This shows the day being edited and allows you 
to change to the next day (right arrow) or the previous day(left arrow).    You can also drag 
the slider right or left to advance or go back up to 31 days.    If you click in the area of the 
scroll bar between the slider, the day will advance or go back by one week.    Also at the top
is the Close button which closes the Event Editor.

Next is the Event List.    This is a scrollable list which shows the events for the current day. 
You can select (click on) events in the Event List to modify or delete them.    

At the bottom is the Event Edit area.    This is where you enter or modify event information.  
Enter the time of the event in the Time box and the text of the event in the Event box.    
You select the type of the event by clicking on the appropriate option button.    The buttons 
at the bottom allow you to Add a new event, Update a modified event, Delete an event, 
or Cancel adding a new event or modifications to an existing event.    



Calendar Display
The Calendar Display is the main display window for Calendar Master.    This window 
shows the calendar of the currently selected month (and the number of events on each 
day), allows you to change the selected month, and allows you to load and save Calendar 
Master files, and exit the program.    

To view a specific month in the Calendar Display, you use the navigation buttons on the left
side of the window.    The month being displayed is shown between the scroll buttons.    The 
inner scroll buttons change the month (the left button changes to the previous month and 
the right button changes to the next month).    The outer scroll buttons change the year.    
You can drag the slider left or right to display previous or future months.    If you click in the 
area between the slider and the buttons, you will jump ahead or back by 3 months.    The 
additional buttons below the scroll buttons allow you to quickly display the current month 
(based on the system clock) or hop directly to a specific month in the currently displayed 
year.    

If you have event information entered into Calendar Master, the number of events (both 
Normal/General and Anniversary events) for each day will be displayed on the calendar.    

To open the Event Editor, click on the desired day on the calendar.

The Toolbar or the menu bar can be used to print, load and save files, and exit the 
program.    



Delete Recurring Event Dialog
This dialog box allows you to specify the subset of events of the selected Recurring event 
to delete.    You can choose to delete 

Just the current event - no other events in the recurring series are changed.

All the events - all the events that match the selected event

All previous events - all the events that match the selected event that occur 
before the selected day.

All future events - all the events that match the selected event that occur after 
the selected day.

Select the option desired and then click OK to carry out the delete.    Cancel aborts the 
delete.




